What’s Vulnerable › Vulnerabilities

CVE-2026-56707: Grav Flex Objects 1.4.0 through 1.4.7 Authorization Bypass via Shortcode

Description

Grav Flex Objects plugin versions 1.4.0 through 1.4.7 contain an authorization bypass vulnerability in the flex-objects shortcode that allows users with page-edit access to render any registered Flex collection without permission checks. Attackers can place the shortcode in published pages to expose sensitive directory contents including user account information, bypassing the authorize ACL enforced in the admin panel.

Affected products

How to fix

Upgrade to a fixed version: getgrav grav 1.4.8. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-56707 or the next vulnerability affects your stack