What’s Vulnerable › Vulnerabilities
CVE-2026-56783: Parseable < 2.9.2 - Cleartext Credential Exposure in Notification Target API
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-29 · updated 2026-10-25
- Weakness: CWE-522
Description
Parseable before 2.9.2 contains an information disclosure vulnerability in the notification-target API endpoints that returns webhook tokens and basic-auth credentials in cleartext due to commented-out secret-masking functionality. Any authenticated user with the GetAlert action, including low-privilege reader roles, can recover credentials and internal endpoint URLs for all configured notification targets by querying GET /api/v1/targets or related endpoints.
Affected products
- parseablehq parseable: before 2.9.2 — fixed in 2.9.2
How to fix
Upgrade to a fixed version: parseablehq parseable 2.9.2. Check the vendor advisory for mitigations.
References
- https://github.com/parseablehq/parseable/commit/f307c4989cc9f3ff4204fd383dec7a39924e6b2a
- https://github.com/parseablehq/parseable/issues/1693
- https://github.com/parseablehq/parseable/pull/1698
- https://github.com/parseablehq/parseable/releases/tag/v2.9.2
- https://www.vulncheck.com/advisories/parseable-cleartext-credential-exposure-in-notification-target-api
- https://github.com/parseablehq/parseable/issues/1693
Get alerted when CVE-2026-56783 or the next vulnerability affects your stack