What’s Vulnerable › Vulnerabilities
CVE-2026-56820: Netty: Missing CertificateID Validation in OCSP Response Allows Replay Attacks
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-21 · updated 2026-07-30
- Weakness: CWE-295
Description
Netty is a network application framework for development of protocol servers and clients. In versions 4.2.0.Final through 4.2.15.Final and prior to 4.1.135.Final, `OcspClient` does not validate that the `CertificateID` in an OCSP response matches the requested `CertificateID`, which can lead to replay attack. `OcspClient.validateResponse` accepts a legitimately signed `GOOD` status response for an unrelated certificate issued by the same CA, allowing bypass of revocation checks for another certificate. This issue is fixed in versions 4.1.136.Final and 4.2.16.Final.
Affected products
- netty: before 4.1.136; from 4.2.0 before 4.2.16 — fixed in 4.1.136, 4.2.16
How to fix
Upgrade to a fixed version: netty 4.1.136, 4.2.16. Check the vendor advisory for mitigations.
References
- https://github.com/netty/netty/commit/5b68c61f37aa4a3045cba624cbea239655c9003b
- https://github.com/netty/netty/commit/bb2ff68a1fb71cb4b0eb9a9e17b66c52aff680c6
- https://github.com/netty/netty/releases/tag/netty-4.1.136.Final
- https://github.com/netty/netty/releases/tag/netty-4.2.16.Final
- https://github.com/netty/netty/security/advisories/GHSA-272m-gcwp-mpwg
Get alerted when CVE-2026-56820 or the next vulnerability affects your stack