What’s Vulnerable › Vulnerabilities
CVE-2026-56821: Netty: Out-of-date OCSP Responses Accepted by OcspServerCertificateValidator
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-29 · updated 2026-08-07
- Weakness: CWE-299
Description
Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, the OcspServerCertificateValidator flags an out-of-date OCSP response but does not stop processing it, so an expired GOOD response is still reported as VALID, letting an on-path attacker replay a stale GOOD response to bypass revocation of a since-revoked certificate. Exploitation can lead to certificate revocation bypass via replay of an expired OCSP response. Any application using OcspServerCertificateValidator is affected; a revoked certificate can be accepted. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.
Affected products
- netty: before 4.1.136; from 4.2.0 before 4.2.16 — fixed in 4.1.136, 4.2.16
How to fix
Upgrade to a fixed version: netty 4.1.136, 4.2.16. Check the vendor advisory for mitigations.
References
- https://github.com/netty/netty/security/advisories/GHSA-g7hg-vrcf-mvmr
- https://github.com/netty/netty/security/advisories/GHSA-g7hg-vrcf-mvmr
Get alerted when CVE-2026-56821 or the next vulnerability affects your stack