What’s Vulnerable › Vulnerabilities
CVE-2026-56826: Shopper: Missing function-level authorization on Settings tax/zone/shipping Livewire components allows a low-privileged user to delete commerce configuration
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-13 · updated 2026-10-17
- Weakness: CWE-862
Description
Shopper is a Headless e-commerce Admin Panel. From 2.0.0 until 2.9.2, authenticated users who could reach the Settings pages with only access_setting could directly invoke destructive actions through the Livewire endpoint because packages/admin/src/Livewire/Components/Settings/Zones/ZoneShippingOptions.php, packages/admin/src/Livewire/Components/Settings/Zones/Detail.php, packages/admin/src/Livewire/Components/Settings/Taxes/Detail.php, and packages/admin/src/Livewire/Components/Settings/Taxes/TaxRates.php did not enforce server-side delete authorization. The actions could delete carrier options, shipping zones, tax zones, and tax rates, disrupting checkout shipping, payment-method mapping, and tax calculation. This issue is fixed in version 2.9.2.
Affected products
- shopperlabs shopper: from 2.0.0, < 2.9.2
References
- https://github.com/shopperlabs/shopper/commit/bf72e2753e21296184596d507336c7d65ecd46ff
- https://github.com/shopperlabs/shopper/pull/570
- https://github.com/shopperlabs/shopper/releases/tag/v2.9.2
- https://github.com/shopperlabs/shopper/security/advisories/GHSA-f7h9-qv4x-9x57
- https://github.com/shopperlabs/shopper/security/advisories/GHSA-f7h9-qv4x-9x57
Get alerted when CVE-2026-56826 or the next vulnerability affects your stack