What’s Vulnerable › Vulnerabilities
CVE-2026-57212: RabbitMQ management HTTP API accepts request bodies larger than configured max_http_body_size
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-10 · updated 2026-10-25
- Weakness: CWE-770
Description
RabbitMQ is a messaging and streaming broker. Prior to 3.13.14, 4.0.19, 4.1.10, and 4.2.5, the rabbitmq_management HTTP API accepts oversized valid JSON bodies on with_decode and direct_request paths because read_complete_body checks the accumulated size before the final chunk but not the final combined size. This issue is fixed in versions 3.13.14, 4.0.19, 4.1.10, and 4.2.5.
Affected products
- rabbitmq-server: from 3.13.0 before 4.2.5 — fixed in 4.2.5
How to fix
Upgrade to a fixed version: rabbitmq-server 4.2.5. Check the vendor advisory for mitigations.
References
- https://github.com/rabbitmq/rabbitmq-server/commit/3976d148901bdfa82e1cd60b7a4534e073266ba5
- https://github.com/rabbitmq/rabbitmq-server/commit/b8fc2ef7c50a2797d15e1ea7cf34f290032303bb
- https://github.com/rabbitmq/rabbitmq-server/pull/15712
- https://github.com/rabbitmq/rabbitmq-server/pull/15714
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.5
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-5cmq-vp28-xqrj
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-5cmq-vp28-xqrj
Get alerted when CVE-2026-57212 or the next vulnerability affects your stack