What’s Vulnerable › Vulnerabilities
CVE-2026-57213: RabbitMQ: Stored XSS federation management plugin via unsanitized consumer_tag rendering
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-10 · updated 2026-10-25
- Weakness: CWE-79
Description
RabbitMQ is a messaging and streaming broker. Prior to 3.13.14, 4.0.19, 4.1.10, and 4.2.5, the rabbitmq_federation_management plugin renders the consumer_tag field on the Federation Status page without HTML escaping, allowing a user who can configure a federation upstream or policy to execute JavaScript in the browser of a user viewing that page. This issue is fixed in versions 3.13.14, 4.0.19, 4.1.10, and 4.2.5.
Affected products
- rabbitmq-server: from 3.13.0 before 4.2.5 — fixed in 4.2.5
How to fix
Upgrade to a fixed version: rabbitmq-server 4.2.5. Check the vendor advisory for mitigations.
References
- https://github.com/rabbitmq/rabbitmq-server/commit/33dedfe4fd53ff009cc67ab36358d0624c6b2e53
- https://github.com/rabbitmq/rabbitmq-server/commit/c2d0d69edf01efbd6e87dfb250c373a32da957f8
- https://github.com/rabbitmq/rabbitmq-server/pull/15708
- https://github.com/rabbitmq/rabbitmq-server/pull/15711
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.5
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-qxrp-7cmp-p77h
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-qxrp-7cmp-p77h
Get alerted when CVE-2026-57213 or the next vulnerability affects your stack