What’s Vulnerable › Vulnerabilities
CVE-2026-57214: RabbitMQ: Stored XSS in RabbitMQ management UI
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-10 · updated 2026-10-25
- Weakness: CWE-79
Description
RabbitMQ is a messaging and streaming broker. Prior to 4.2.5, the RabbitMQ management UI renders the x-internal-purpose queue or exchange argument into an HTML title attribute without proper escaping on the Queues and Exchanges pages, allowing a user with permission to declare a queue or exchange to execute JavaScript in another user's browser. This issue is fixed in version 4.2.5.
Affected products
- rabbitmq-server: from 4.2.0 before 4.2.5 — fixed in 4.2.5
How to fix
Upgrade to a fixed version: rabbitmq-server 4.2.5. Check the vendor advisory for mitigations.
References
- https://github.com/rabbitmq/rabbitmq-server/commit/b0027b6c1ae5b869d876e211efe6189ffd92b5c2
- https://github.com/rabbitmq/rabbitmq-server/commit/b267a290dd89e42c6e0256f46fc273a8adb7f3ec
- https://github.com/rabbitmq/rabbitmq-server/pull/15606
- https://github.com/rabbitmq/rabbitmq-server/pull/15608
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.5
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-6jfq-prw2-7rwp
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-6jfq-prw2-7rwp
Get alerted when CVE-2026-57214 or the next vulnerability affects your stack