What’s Vulnerable › Vulnerabilities
CVE-2026-57216: RabbitMQ: AMQP 1.0, AMQP 0-9-1, Stream Protocol loopback enforcement can lead to remote guest sessions due to listener-address loopback checks
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-10 · updated 2026-10-25
- Weakness: CWE-287
Description
RabbitMQ is a messaging and streaming broker. Prior to 3.13.15, 4.0.20, 4.1.11, and 4.2.6, AMQP 0-9-1, AMQP 1.0, and Stream Protocol authentication can allow a loopback-restricted user such as guest to connect remotely when traffic is accepted through a trusted PROXY-protocol path and the backend listener is loopback-bound because the loopback check uses the listener-side socket address instead of the real client source. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, and 4.2.6.
Affected products
- rabbitmq-server: from 3.13.0 before 3.13.15; from 4.0.0 before 4.0.20; from 4.1.0 before 4.1.11; from 4.2.0 before 4.2.6 — fixed in 3.13.15, 4.0.20, 4.1.11, 4.2.6
How to fix
Upgrade to a fixed version: rabbitmq-server 3.13.15, 4.0.20, 4.1.11, 4.2.6. Check the vendor advisory for mitigations.
References
- https://github.com/rabbitmq/rabbitmq-server/commit/7273c9eb6920abcde17b892dbe97ccaf906ead47
- https://github.com/rabbitmq/rabbitmq-server/commit/9f8c39fcf0acbc43080ee7017a62a02832114112
- https://github.com/rabbitmq/rabbitmq-server/pull/15936
- https://github.com/rabbitmq/rabbitmq-server/pull/15940
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.6
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-36m6-588r-vqcw
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-36m6-588r-vqcw
Get alerted when CVE-2026-57216 or the next vulnerability affects your stack