What’s Vulnerable › Vulnerabilities
CVE-2026-57220: RabbitMQ: Stream listener does not enforce configured frame-size limit during authentication, permitting unauth'd mem-exhaust DoS
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-10 · updated 2026-10-25
- Weakness: CWE-770
Description
RabbitMQ is a messaging and streaming broker. Prior to 4.2.6, the RabbitMQ stream listener does not enforce the configured stream frame-size limit while assembling frames during authentication and before Tune negotiation, allowing an unauthenticated remote client to declare oversized frame lengths and consume broker memory in rabbit_stream_core. This issue is fixed in version 4.2.6.
Affected products
- rabbitmq-server: from 4.2.0 before 4.2.6 — fixed in 4.2.6
How to fix
Upgrade to a fixed version: rabbitmq-server 4.2.6. Check the vendor advisory for mitigations.
References
- https://github.com/rabbitmq/rabbitmq-server/commit/595ec28fa1621b1f2c28124e4e0466a8ad963547
- https://github.com/rabbitmq/rabbitmq-server/commit/773a49c4921e8be990262a2d609c35916825679e
- https://github.com/rabbitmq/rabbitmq-server/pull/16171
- https://github.com/rabbitmq/rabbitmq-server/pull/16173
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.6
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-f364-87q5-j35q
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-f364-87q5-j35q
Get alerted when CVE-2026-57220 or the next vulnerability affects your stack