What’s Vulnerable › Vulnerabilities
CVE-2026-57221: RabbitMQ: Passive queue/exchange declaration bypasses authorization checks, leaking queue metadata to unprivileged users
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-10 · updated 2026-10-25
- Weakness: CWE-862
Description
RabbitMQ is a messaging and streaming broker. Prior to 3.13.15, 4.0.20, 4.1.11, and 4.2.6, RabbitMQ does not perform authorization checks on passive queue.declare and exchange.declare AMQP 0-9-1 operations, allowing any authenticated user who can connect to a virtual host to enumerate queue and exchange names and read queue message and consumer counts. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, and 4.2.6.
Affected products
- rabbitmq-server: from 3.13.0 before 4.2.6 — fixed in 4.2.6
How to fix
Upgrade to a fixed version: rabbitmq-server 4.2.6. Check the vendor advisory for mitigations.
References
- https://github.com/rabbitmq/rabbitmq-server/commit/709a14e49e06c138a8cd672c9809ca34a2767962
- https://github.com/rabbitmq/rabbitmq-server/commit/dc3d1aa4f5c3331a425ee599b45be9423a2e83fc
- https://github.com/rabbitmq/rabbitmq-server/pull/16085
- https://github.com/rabbitmq/rabbitmq-server/pull/16090
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.6
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-9q2j-2hq8-22r2
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-9q2j-2hq8-22r2
Get alerted when CVE-2026-57221 or the next vulnerability affects your stack