What’s Vulnerable › Vulnerabilities
CVE-2026-57235: Nokogiri: Possible Out-of-Bounds Read in `Nokogiri::XML::NodeSet#[]`
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-25 · updated 2026-10-25
- Weakness: CWE-125
Description
Nokogiri is an open source XML and HTML library for the Ruby programming language. Prior to 1.19.4, Nokogiri::XML::NodeSet#[] (and its alias #slice) checked the requested index against the node set's bounds using a 32-bit-truncated copy of the index. A large negative index could pass the check and then be used at full width, reading outside the node set's storage. On CRuby this is an out-of-bounds read that typically crashes the process; on JRuby it is not memory-unsafe but returns an incorrect node. This vulnerability is fixed in 1.19.4.
Affected products
- sparklemotion nokogiri: before 1.19.4 — fixed in 1.19.4
- Rubygems Nokogiri: before 1.19.4; 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5 (+188) — fixed in 1.19.4
How to fix
Upgrade to a fixed version: sparklemotion nokogiri 1.19.4; Rubygems Nokogiri 1.19.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-57235 or the next vulnerability affects your stack