What’s Vulnerable › Vulnerabilities
CVE-2026-57236: Nokogiri: Possible Use-After-Free when `Nokogiri::XML::Document#encoding=` raises an exception
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-25 · updated 2026-10-25
- Weakness: CWE-416
Description
Nokogiri is an open source XML and HTML library for the Ruby programming language. Prior to 1.19.4, calling Document#encoding= with an invalid encoding (e.g., a non-string, or a string containing a null byte) raises an exception, but only after freeing the document's current encoding string without replacing it. The document is left referencing freed memory, so the next call to Document#encoding reads invalid memory, which can cause a segfault or leak freed bytes into a Ruby String. Affects the CRuby (libxml2) implementation only; JRuby is not affected. This vulnerability is fixed in 1.19.4.
Affected products
- sparklemotion nokogiri: before 1.19.4 — fixed in 1.19.4
- Rubygems Nokogiri: before 1.19.4; 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5 (+188) — fixed in 1.19.4
How to fix
Upgrade to a fixed version: sparklemotion nokogiri 1.19.4; Rubygems Nokogiri 1.19.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-57236 or the next vulnerability affects your stack