What’s Vulnerable › Vulnerabilities

CVE-2026-57308: Apache Syncope: SQL injection vulnerability in Audit Events search

Description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Syncope. An administrator with adequate entitlements can achieve execution of arbitrary SQL via stacked queries, leveraging unsanitized sort parameters. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.6, from 4.1.0-M0 through 4.1.1. Users are recommended to upgrade to version 4.0.7 / 4.1.2, which fix this issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache Syncope 4.0.7, 4.1.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-57308 or the next vulnerability affects your stack