What’s Vulnerable › Vulnerabilities
CVE-2026-57434: Nokogiri: Null Pointer Dereference calling methods on uninitialized wrapper classes
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-25 · updated 2026-10-25
- Weakness: CWE-476
Description
Nokogiri is an open source XML and HTML library for the Ruby programming language. Prior to 1.19.4, Nokogiri contains a bug when calling certain methods on allocated-but-uninitialized native wrapper classes that inherit from Nokogiri::XML::Node. This caused a NULL pointer dereference that could crash the process. This vulnerability is fixed in 1.19.4.
Affected products
- sparklemotion nokogiri: before 1.19.4 — fixed in 1.19.4
- Rubygems Nokogiri: before 1.19.4; 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5 (+188) — fixed in 1.19.4
How to fix
Upgrade to a fixed version: sparklemotion nokogiri 1.19.4; Rubygems Nokogiri 1.19.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-57434 or the next vulnerability affects your stack