What’s Vulnerable › Vulnerabilities
CVE-2026-57436: Nokogiri: Possible Use-After-Free when setting `Document#root=` to an invalid node type
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-25 · updated 2026-10-25
- Weakness: CWE-416
Description
Nokogiri is an open source XML and HTML library for the Ruby programming language. Prior to 1.19.4, Nokogiri::XML::Document#root= validated only that the new root was a Nokogiri::XML::Node, allowing a DTD node to be set as the document root. The result is a heap use-after-free during garbage collection or finalization, leading to an invalid memory read or potentially a segfault. This vulnerability is fixed in 1.19.4.
Affected products
- sparklemotion nokogiri: before 1.19.4 — fixed in 1.19.4
- Rubygems Nokogiri: before 1.19.4; 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5 (+188) — fixed in 1.19.4
How to fix
Upgrade to a fixed version: sparklemotion nokogiri 1.19.4; Rubygems Nokogiri 1.19.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-57436 or the next vulnerability affects your stack