What’s Vulnerable › Vulnerabilities
CVE-2026-57453: Vim: PowerShell Command Injection via Unescaped Filename in zip.vim Extraction
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-25 · updated 2026-06-26
- Weakness: CWE-77
Description
Vim is an open source, command line text editor. From 9.1.1784 until 9.2.0678, when the bundled zip plugin autoload/zip.vim falls back to PowerShell to browse, read, extract, update or delete entries in a zip archive, it builds the PowerShell command by inserting archive entry names that are quoted only for the shell, not for PowerShell. A crafted entry name can break out of the intended string context and cause PowerShell to execute arbitrary commands with the privileges of the user running Vim, triggered by opening, viewing or extracting the archive. This vulnerability is fixed in 9.2.0678.
Affected products
- vim/vim: from 9.1.1784 before 9.2.0678 — fixed in 9.2.0678
How to fix
Upgrade to a fixed version: vim/vim 9.2.0678. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/b2cc9be119d51212bf0d3f2a99
- https://github.com/vim/vim/releases/tag/v9.2.0678
- https://github.com/vim/vim/security/advisories/GHSA-x5fg-h5w9-9frf
Get alerted when CVE-2026-57453 or the next vulnerability affects your stack