What’s Vulnerable › Vulnerabilities
CVE-2026-57456: Vim: Arbitrary Code Execution via Python Omni-Completion Docstrings
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-25 · updated 2026-06-26
- Weakness: CWE-94
Description
Vim is an open source, command line text editor. Prior to 9.2.0699, Vim's Python omni-completion (runtime/autoload/python3complete.vim and the legacy pythoncomplete.vim) executes reconstructed function and class definitions from the current buffer with exec() as part of populating the completion dictionary. When reconstructing that source, each scope's docstring is inserted verbatim between triple quotes with no escaping, so a hostile buffer can break out of the triple-quoted literal and execute attacker-controlled Python during omni-completion. This vulnerability is fixed in 9.2.0699.
Affected products
- vim/vim: before 9.2.0699 — fixed in 9.2.0699
How to fix
Upgrade to a fixed version: vim/vim 9.2.0699. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/cce141c42740f122dd8486ae04e21c2a81016ba8
- https://github.com/vim/vim/releases/tag/v9.2.0699
- https://github.com/vim/vim/security/advisories/GHSA-ppj8-wqjf-6fp3
Get alerted when CVE-2026-57456 or the next vulnerability affects your stack