What’s Vulnerable › Vulnerabilities
CVE-2026-57480: Parse Server: Denial of service via exponential-time processing of deeply nested query operators
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-08 · updated 2026-10-25
- Weakness: CWE-407
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.9.1-alpha.12 and 8.6.82, deeply nested $or, $and, and $nor query condition operators in the REST API or LiveQuery query handling could trigger exponential-time processing in the internal query-traversal helper and block the Node.js event loop. This issue is fixed in versions 9.9.1-alpha.12 and 8.6.82.
Affected products
- parse-community parse-server: from 9.0.0-alpha.1, < 9.9.1-alpha.12; before 8.6.82
References
- https://github.com/parse-community/parse-server/commit/0f5d2ad77b422dc904458254548be87397fc6e9b
- https://github.com/parse-community/parse-server/commit/1103c7a890e0455ba3dccd4bc5db17efe1789c9a
- https://github.com/parse-community/parse-server/pull/10511
- https://github.com/parse-community/parse-server/pull/10512
- https://github.com/parse-community/parse-server/releases/tag/8.6.82
- https://github.com/parse-community/parse-server/releases/tag/9.9.1-alpha.12
- https://github.com/parse-community/parse-server/security/advisories/GHSA-cgxm-vr2f-6fj8
Get alerted when CVE-2026-57480 or the next vulnerability affects your stack