What’s Vulnerable › Vulnerabilities
CVE-2026-57510: SuperPlane < 0.27.0 Broken Object Level Authorization via CanvasService gRPC
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-28 · updated 2026-10-23
- Weakness: CWE-639
Description
SuperPlane before 0.27.0 contains a broken object-level authorization vulnerability in the CanvasService gRPC handlers that allows authenticated users with viewer-level access to one organization to access resources belonging to other organizations by supplying arbitrary canvas or queue UUIDs without organization scoping. Attackers can read cross-tenant execution history and event payloads containing sensitive secrets, write queue items and canvas events into victim organizations, delete arbitrary canvases, and disrupt automation workflows across tenant boundaries.
Affected products
- superplanehq superplane: before 0.27.0 — fixed in 0.27.0
How to fix
Upgrade to a fixed version: superplanehq superplane 0.27.0. Check the vendor advisory for mitigations.
References
- https://github.com/superplanehq/superplane/commit/3e45cf4f1b5f1be9fbbfd90c97960a73f00f897b
- https://github.com/superplanehq/superplane/pull/5635
- https://github.com/superplanehq/superplane/releases/tag/v0.27.0
- https://www.vulncheck.com/advisories/superplane-broken-object-level-authorization-via-canvasservice-grpc
Get alerted when CVE-2026-57510 or the next vulnerability affects your stack