What’s Vulnerable › Vulnerabilities
CVE-2026-57516: Ray < 2.56.0 Unsafe Deserialization RCE via WebDataset Reader
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-01 · updated 2026-10-25
- Weakness: CWE-502
Description
Ray prior to 2.56.0 contains an unsafe deserialization vulnerability in the WebDataset reader that allows attackers to achieve remote code execution by supplying a malicious tar archive to the read_webdataset() function. The _default_decoder() function in webdataset_datasource.py unconditionally calls pickle.loads() on tar entries with .pkl/.pickle extensions and torch.load() with weights_only=False on .pt/.pth entries, executing arbitrary code inside Ray remote workers on every worker that processes the malicious archive.
Affected products
- ray-project ray: before 2.56.0 — fixed in 2.56.0
How to fix
Upgrade to a fixed version: ray-project ray 2.56.0. Check the vendor advisory for mitigations.
References
- https://github.com/ray-project/ray/pull/63469
- https://github.com/ray-project/ray/pull/63470
- https://github.com/ray-project/ray/releases/tag/ray-2.56.0
- https://github.com/ray-project/ray/security/advisories/GHSA-hhrp-gw25-jr43
- https://www.vulncheck.com/advisories/ray-unsafe-deserialization-rce-via-webdataset-reader
- https://github.com/ray-project/ray/security/advisories/GHSA-hhrp-gw25-jr43
Get alerted when CVE-2026-57516 or the next vulnerability affects your stack