What’s Vulnerable › Vulnerabilities
CVE-2026-57777: WordPress WooCommerce plugin < 11.0 - SQL Injection vulnerability
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-04 · updated 2026-09-04
- Weakness: CWE-89
Description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Automattic WooCommerce allows Blind SQL Injection. This issue affects WooCommerce: from n/a before 11.0.
Affected products
- Automattic WooCommerce: before 11.0 — fixed in 11.0
How to fix
Upgrade to a fixed version: Automattic WooCommerce 11.0. Check the vendor advisory for mitigations.
References
- https://github.com/woocommerce/woocommerce/pull/67554
- https://patchstack.com/database/wordpress/plugin/woocommerce/vulnerability/wordpress-woocommerce-plugin-10-9-4-sql-injection-vulnerability?_s_id=cve
Get alerted when CVE-2026-57777 or the next vulnerability affects your stack