What’s Vulnerable › Vulnerabilities
CVE-2026-57817: Apache CXF: The authorization code hash (c_hash) is not enforced for the hybrid OIDC flow
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-06 · updated 2026-10-24
- Weakness: CWE-20
Description
The OpenID Connect Core 1.0 specification mandates that the RP MUST validate the `c_hash` parameter when operating in the Hybrid Flow. If an Apache CXF RP is integrated with a non-compliant or misconfigured Identity Provider (IdP) that omits the `c_hash`, the RP becomes vulnerable to Authorization Code Substitution/Injection attacks. Users are recommended to upgrade to versions 4.2.3 or 4.1.8 or 3.6.12, which fix this issue.
Affected products
- Apache Software Foundation Apache CXF: before 3.6.12; from 4.0.0 before 4.1.8; from 4.2.0 before 4.2.3 — fixed in 3.6.12, 4.1.8, 4.2.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache CXF 3.6.12, 4.1.8, 4.2.3. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/pj63c3pf7kkp1xhr53do704fwj3t3htn
- http://www.openwall.com/lists/oss-security/2026/08/06/19
Get alerted when CVE-2026-57817 or the next vulnerability affects your stack