What’s Vulnerable › Vulnerabilities
CVE-2026-57910: WatchGuard Agent improper authentication allows unauthenticated remote code execution
- Severity: critical (CVSS 9.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-25 · updated 2026-09-28
- Weakness: CWE-306
Description
Improper authentication in the WatchGuard Agent allows an unauthenticated attacker with network access to cause the agent to execute arbitrary code with elevated privileges.
Affected products
- WatchGuard Agent: before 1.17.01.0000; before 1.25.13.0000; before 1.17.21.0000 — fixed in 1.17.01.0000, 1.17.21.0000, 1.25.13.0000
How to fix
Upgrade to a fixed version: WatchGuard Agent 1.17.01.0000, 1.17.21.0000, 1.25.13.0000. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-57910 or the next vulnerability affects your stack