What’s Vulnerable › Vulnerabilities
CVE-2026-57914: Apache Kerby: StackOverflow on parsing deeply nested ASN1 structures
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-26 · updated 2026-10-25
- Weakness: CWE-400
Description
By sending a deeply nested ASN1 structure to a Apache Kerby client or service, it's possible to trigger a StackOverFlow Exception which can lead to denial of service issues. Users are recommended to upgrade to version 2.1.2, which fixes this issue.
Affected products
- Apache Software Foundation Apache Kerby: before 2.1.2 — fixed in 2.1.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Kerby 2.1.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/w98h2q8wz0bq97vhz4vf55hqomcb2j1m
- http://www.openwall.com/lists/oss-security/2026/06/26/7
Get alerted when CVE-2026-57914 or the next vulnerability affects your stack