What’s Vulnerable › Vulnerabilities
CVE-2026-57915: Apache Kerby: Kerberos Pre-Authentication Bypass
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-26 · updated 2026-10-25
- Weakness: CWE-304
Description
It is possible to bypass the Kerberos pre-authentication check in Apache Kerby by sending a PA-DATA with an unrecognized or unsupported type. Users are recommended to upgrade to version 2.1.2, which fixes this issue.
Affected products
- Apache Software Foundation Apache Kerby: before 2.1.2 — fixed in 2.1.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Kerby 2.1.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/1y3glgh3kzwoxo5m2lq504cjlh1dsrfh
- http://www.openwall.com/lists/oss-security/2026/06/26/8
- https://access.redhat.com/security/cve/CVE-2026-57915
- https://bugzilla.redhat.com/show_bug.cgi?id=2493407
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-57915.json
Get alerted when CVE-2026-57915 or the next vulnerability affects your stack