What’s Vulnerable › Vulnerabilities
CVE-2026-57968: Windows Subsystem for Linux (WSL2) Kernel Elevation of Privilege Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-14 · updated 2026-10-28
- Weakness: CWE-126
Description
Buffer over-read in Windows Subsystem for Linux allows an authorized attacker to elevate privileges locally.
Affected products
- Microsoft Windows Subsystem for Linux (WSL2): before 2.7.8 — fixed in 2.7.8
- Microsoft Windows Subsystem for Linux (WSL2): from 5.0.0.0 before 2.7.8 — fixed in 2.7.8
How to fix
Upgrade to a fixed version: Microsoft Windows Subsystem for Linux (WSL2) 2.7.8; Microsoft Windows Subsystem for Linux (WSL2) 2.7.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-57968 or the next vulnerability affects your stack