What’s Vulnerable › Vulnerabilities
CVE-2026-57995: phpMyFAQ - Privilege Escalation via Missing Self-Rights Constraint in GroupController::updatePermissions
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-30 · updated 2026-07-02
- Weakness: CWE-269
Description
phpMyFAQ before 4.1.5 contains a privilege escalation vulnerability in GroupController::updatePermissions that allows GROUP_EDIT administrators to grant arbitrary rights to groups without verifying they hold those rights themselves. A delegated administrator can exploit this by assigning high-value permissions to a group they belong to, inheriting those rights and escalating privileges up to full administrative control.
Affected products
- thorsten phpMyFAQ: before 4.1.5 — fixed in 4.1.5
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.1.5. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-pg62-f8g4-4wqh
- https://www.vulncheck.com/advisories/phpmyfaq-privilege-escalation-via-missing-self-rights-constraint-in-groupcontroller-updatepermissions
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-pg62-f8g4-4wqh
Get alerted when CVE-2026-57995 or the next vulnerability affects your stack