What’s Vulnerable › Vulnerabilities
CVE-2026-57996: phpMyFAQ - Privilege Escalation via Missing SuperAdmin Guard in user/add Endpoint
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-15 · updated 2026-07-16
- Weakness: CWE-269
Description
phpMyFAQ before 4.1.5 contains a privilege escalation vulnerability in the user/add API endpoint that allows non-SuperAdmin administrators to create SuperAdmin accounts. A delegated administrator with USER_ADD/EDIT/DELETE permissions can call POST /admin/api/user/add with isSuperAdmin: true and attacker-chosen credentials to create a SuperAdmin account, then authenticate as that account to achieve full instance takeover.
Affected products
- thorsten phpMyFAQ: before 4.1.5 — fixed in 4.1.5
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.1.5. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-r2f4-v277-hvw9
- https://www.vulncheck.com/advisories/phpmyfaq-privilege-escalation-via-missing-superadmin-guard-in-user-add-endpoint
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-r2f4-v277-hvw9
Get alerted when CVE-2026-57996 or the next vulnerability affects your stack