What’s Vulnerable › Vulnerabilities
CVE-2026-58014: Glib: off-by-one error in glib/gkeyfile.c via "g_key_file_get_locale_string_list"
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-30 · updated 2026-10-30
- Weakness: CWE-193
Description
A flaw was found in GLib. An off-by-one error can occur in the g_key_file_get_locale_string_list function in the gkeyfile.c file when loading a key file with an empty value. This flaw can cause an out-of-bounds access of 1 byte or a denial of service when the out-of-bounds access crosses a page boundary.
Affected products
- GNOME GLib: before 2.88.1 — fixed in 2.88.1
- Red Hat Enterprise Linux: 6.0, 7.0, 8.0, 9.0, 10.0 (and their updates)
- GNOME GLib: before 2.88.1 — fixed in 2.88.1
- Red Hat Cert Manager support for Red Hat OpenShift release 1.17: all versions — fixed in 1791371080
- Red Hat Cert Manager support for Red Hat OpenShift release 1.18: all versions — fixed in 1791459707
- Red Hat Cert Manager support for Red Hat OpenShift release 1.19: all versions — fixed in 1788348522
- Red Hat Cert Manager support for Red Hat OpenShift release 1.20: all versions — fixed in 1790223279
- Red Hat OpenShift Container Platform 4.18: all versions — fixed in 418.94.202610242013-0
- Red Hat AI Inference Server 3.2: all versions — fixed in 1790621714
- Red Hat AI Inference Server 3.5: all versions — fixed in 1791425869
- Red Hat Discovery 2: all versions — fixed in 1788205779
- Red Hat Enterprise Linux 10: all versions — fixed in 0:2.80.4-12.el10_2.21
- Red Hat Enterprise Linux 10.0 Extended Update Support: all versions — fixed in 0:2.80.4-4.el10_0.17
- Red Hat Enterprise Linux 6: all versions
- Red Hat Enterprise Linux 7 Extended Lifecycle Support: all versions — fixed in 0:2.56.1-13.el7_9.1
- Red Hat Enterprise Linux 8: all versions — fixed in 0:2.70.1-9.el8_10
- Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support: all versions — fixed in 0:2.56.4-10.el8_4.7
- Red Hat Enterprise Linux 8.4 Extended Update Support Long-Life Add-On: all versions — fixed in 0:2.56.4-10.el8_4.7
- Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support: all versions — fixed in 0:2.56.4-158.el8_6.7
- Red Hat Enterprise Linux 8.6 Extended Update Support Long-Life Add-On: all versions — fixed in 0:2.56.4-158.el8_6.7
- Red Hat Enterprise Linux 8.8 Telecommunications Update Service: all versions — fixed in 0:2.56.4-165.el8_8.2
- Red Hat Enterprise Linux 8.8 Update Services for SAP Solutions: all versions — fixed in 0:2.56.4-165.el8_8.2
- Red Hat Enterprise Linux 9: all versions — fixed in 0:2.68.4-19.el9_8.9
- Red Hat Enterprise Linux 9.2 Update Services for SAP Solutions: all versions — fixed in 0:2.68.4-7.el9_2.7
- Red Hat Enterprise Linux 9.4 Update Services for SAP Solutions: all versions — fixed in 0:2.68.4-14.el9_4.8
- Red Hat Enterprise Linux 9.6 Extended Update Support: all versions — fixed in 0:2.68.4-16.el9_6.7
- Red Hat Enterprise Linux AI 3.5: all versions — fixed in 1793206758
- Red Hat OpenShift AI 3.0: all versions — fixed in 1790276886
- Red Hat OpenShift AI 3.2: all versions — fixed in 1790703497
- Red Hat OpenShift AI 3.4: all versions — fixed in 1790703542
How to fix
Upgrade to a fixed version: GNOME GLib 2.88.1; GNOME GLib 2.88.1; Red Hat Cert Manager support for Red Hat OpenShift release 1.17 1791371080; Red Hat Cert Manager support for Red Hat OpenShift release 1.18 1791459707; Red Hat Cert Manager support for Red Hat OpenShift release 1.19 1788348522; Red Hat Cert Manager support for Red Hat OpenShift release 1.20 1790223279; Red Hat OpenShift Container Platform 4.18 418.94.202610242013-0; Red Hat AI Inference Server 3.2 1790621714; Red Hat AI Inference Server 3.5 1791425869; Red Hat Discovery 2 1788205779; Red Hat Enterprise Linux 10 0:2.80.4-12.el10_2.21; Red Hat Enterprise Linux 10.0 Extended Update Support 0:2.80.4-4.el10_0.17. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2026:49512
- https://access.redhat.com/errata/RHSA-2026:55440
- https://access.redhat.com/errata/RHSA-2026:57015
- https://access.redhat.com/errata/RHSA-2026:58981
- https://access.redhat.com/errata/RHSA-2026:61766
- https://access.redhat.com/errata/RHSA-2026:61783
- https://access.redhat.com/errata/RHSA-2026:63135
- https://access.redhat.com/errata/RHSA-2026:63138
- https://access.redhat.com/errata/RHSA-2026:63140
- https://access.redhat.com/errata/RHSA-2026:65762
- https://access.redhat.com/errata/RHSA-2026:65763
- https://access.redhat.com/errata/RHSA-2026:65767
Get alerted when CVE-2026-58014 or the next vulnerability affects your stack