What’s Vulnerable › Vulnerabilities
CVE-2026-58032: mw.Api.getErrorMessage() may return injected HTML if used without errorformat=html
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-01 · updated 2026-10-25
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files resources/src/mediawiki.Api/index.Js. This issue affects MediaWiki: from * before 1.46.0, 1.45.4, 1.44.6, 1.43.9.
Affected products
- Wikimedia Foundation MediaWiki: from 1.43.0 before 1.43.9; from 1.44.0 before 1.44.6; from 1.45.0 before 1.45.4; 1.46.0-rc0 — fixed in 1.43.9, 1.44.6, 1.45.4
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.43.9, 1.44.6, 1.45.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-58032 or the next vulnerability affects your stack