What’s Vulnerable › Vulnerabilities
CVE-2026-58046
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-30 · updated 2026-10-23
- Weakness: CWE-89
Description
Improper neutralization in the Plesk XML-RPC API allows a remote authenticated low-privileged user to perform SQL injection and read arbitrary data from the Plesk database, leading to full compromise of the panel.
Affected products
- WebPros Plesk: before 18.0.79.4 — fixed in 18.0.79.4
How to fix
Upgrade to a fixed version: WebPros Plesk 18.0.79.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-58046 or the next vulnerability affects your stack