What’s Vulnerable › Vulnerabilities
CVE-2026-58151: Apache Traffic Server: Abusive HTTP/2 framing can exhaust resources and crash the server
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-29 · updated 2026-10-01
- Weakness: CWE-400
Description
Apache Traffic Server can be crashed or driven to resource exhaustion by abusive HTTP/2 framing and flow-control. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.
Affected products
- Apache Software Foundation Apache Traffic Server: from 8.0.0 through 8.1.9; from 9.0.0 before 9.2.15; from 10.0.0 before 10.1.4 — fixed in 10.1.4, 9.2.15
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Traffic Server 10.1.4, 9.2.15. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-58151 or the next vulnerability affects your stack