What’s Vulnerable › Vulnerabilities

CVE-2026-5816: Improper Resolution of Path Equivalence in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.10 before 18.10.4 and 18.11 before 18.11.1 that could have allowed an unauthenticated user to execute arbitrary JavaScript in a user's browser session due to improper path validation under certain conditions.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.10.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-5816 or the next vulnerability affects your stack