What’s Vulnerable › Vulnerabilities
CVE-2026-58167: Nightingale < 9.0.0-beta.2 - Datasource Credential Disclosure to Low-Privilege Users
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-30 · updated 2026-10-25
- Weakness: CWE-862
Description
Nightingale (n9e) before 9.0.0-beta.2 exposes full datasource configurations, including plaintext database passwords, HTTP bearer tokens, HTTP basic-auth passwords, and mTLS client keys, to any authenticated low-privilege (Standard role) user through POST /api/n9e/datasource/list. The route is registered without an admin authorization gate, unlike the sibling datasource mutation routes, and the open-source DatasourceFilter does not redact secret fields, so the secret-bearing settings, http, and auth objects are serialized in the response. The disclosed credentials enable access to the connected downstream systems.
Affected products
- ccfos nightingale: before 9.0.0-beta.2 — fixed in 9.0.0-beta.2
How to fix
Upgrade to a fixed version: ccfos nightingale 9.0.0-beta.2. Check the vendor advisory for mitigations.
References
- https://github.com/ccfos/nightingale/commit/762819fbaa2350b73bce45bfaf6f8cf74b4abef8
- https://github.com/ccfos/nightingale/issues/3173
- https://github.com/ccfos/nightingale/pull/3175
- https://github.com/ccfos/nightingale/releases/tag/v9.0.0-beta.2
- https://www.vulncheck.com/advisories/nightingale-beta-2-datasource-credential-disclosure-to-low-privilege-users
Get alerted when CVE-2026-58167 or the next vulnerability affects your stack