What’s Vulnerable › Vulnerabilities
CVE-2026-58168: DeepTutor < 1.4.10 - Insecure Default Grants Unrestricted MCP Tool Access to Non-Admin Users
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-30 · updated 2026-10-25
- Weakness: CWE-862
Description
DeepTutor before version 1.4.10 contains an authorization bypass vulnerability that allows low-privilege users to invoke unrestricted MCP tools due to the allowed_mcp_tools function returning None instead of a denied result when mcp_tools is omitted from a user's grant in deeptutor/multi_user/tool_access.py. Attackers or prompt-injected content acting within a user session can enumerate and invoke any configured MCP tool, including filesystem, shell, and browser servers, gaining unauthorized access to sensitive deployment resources.
Affected products
- HKUDS DeepTutor: before 1.4.10 — fixed in 1.4.10
How to fix
Upgrade to a fixed version: HKUDS DeepTutor 1.4.10. Check the vendor advisory for mitigations.
References
- https://github.com/HKUDS/DeepTutor/commit/90046374b3dcd4f8a866d2d64a64440bc08eb2ef
- https://github.com/HKUDS/DeepTutor/pull/579
- https://github.com/HKUDS/DeepTutor/releases/tag/v1.4.10
- https://www.vulncheck.com/advisories/deeptutor-insecure-default-grants-unrestricted-mcp-tool-access-to-non-admin-users
- https://github.com/HKUDS/DeepTutor/pull/579
Get alerted when CVE-2026-58168 or the next vulnerability affects your stack