What’s Vulnerable › Vulnerabilities
CVE-2026-58177: Apache Traffic Server: Memory-safety and path-traversal errors in the Cripts framework
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-29 · updated 2026-10-23
- Weakness: CWE-787
Description
The Apache Traffic Server Cripts framework has out-of-bounds writes, path traversal, and use-after-free errors. This issue affects Apache Traffic Server: from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 10.1.4, which fix the issue.
Affected products
- Apache Software Foundation Apache Traffic Server: from 10.0.0 before 10.1.4 — fixed in 10.1.4
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Traffic Server 10.1.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-58177 or the next vulnerability affects your stack