What’s Vulnerable › Vulnerabilities

CVE-2026-58184: Apache Traffic Server: header_rewrite plugin cookie handling can corrupt memory

Description

The Apache Traffic Server header_rewrite plugin can crash or corrupt memory during cookie operations and CIDR condition matching. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache Traffic Server 10.1.4, 9.2.15. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-58184 or the next vulnerability affects your stack