What’s Vulnerable › Vulnerabilities

CVE-2026-58187: Apache Traffic Server: Multiplexer plugin chunk decoder enables a denial of service

Description

The Apache Traffic Server multiplexer plugin overruns its chunk-decode buffer on upstream input, enabling denial of service. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache Traffic Server 10.1.4, 9.2.15. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-58187 or the next vulnerability affects your stack