What’s Vulnerable › Vulnerabilities
CVE-2026-58207: NATS Server: Remote crash via integer overflow in Connz pagination
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-08 · updated 2026-10-25
- Weakness: CWE-190
Description
NATS Server is a high-performance server for NATS.io, the cloud and edge native messaging system. Prior to 2.14.3 and 2.12.12, a client able to send account-scoped connection monitoring requests could crash the server by supplying Connz pagination Offset and Limit values that overflowed internal arithmetic before the response window was safely bounded. This issue is fixed in versions 2.14.3 and 2.12.12.
Affected products
- nats-io nats-server: from 2.12.0 before 2.12.12; from 2.14.0 before 2.14.3 — fixed in 2.12.12, 2.14.3
How to fix
Upgrade to a fixed version: nats-io nats-server 2.12.12, 2.14.3. Check the vendor advisory for mitigations.
References
- https://github.com/nats-io/nats-server/commit/2ae047139e37a38cb01e259a67909e7a39fa38e9
- https://github.com/nats-io/nats-server/commit/894d9411927681d66ce349bf1afe49608dc0c1a3
- https://github.com/nats-io/nats-server/releases/tag/v2.12.12
- https://github.com/nats-io/nats-server/releases/tag/v2.14.3
- https://github.com/nats-io/nats-server/security/advisories/GHSA-q59r-vq66-pxc2
Get alerted when CVE-2026-58207 or the next vulnerability affects your stack