What’s Vulnerable › Vulnerabilities
CVE-2026-58226: Unauthenticated denial-of-service via unbounded HPACK integer decoding in hpax
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-06 · updated 2026-10-25
- Weakness: CWE-407
Description
Inefficient Algorithmic Complexity vulnerability in elixir-mint hpax allows unauthenticated denial-of-service via unbounded HPACK integer decoding. hpax decodes HPACK variable-length integers with no upper bound on the decoded value or the number of continuation octets. 'Elixir.HPAX.Types':decode_remaining_integer/3 accumulates the integer as int + (value <<< m), shifting by 7 more bits for each continuation octet and stopping only on a terminating octet or truncated input, never because the integer grew too large. Because BEAM integers are arbitrary precision, a run of N continuation octets builds an O(N)-bit bignum and re-adds into an ever-larger bignum on each step, so the total decoding cost is superlinear (about O(N^2)). An unauthenticated attacker who can send an HTTP/2 header block to a server using this decoder (reached through the 'Elixir.HPAX':decode/2 entry point) can supply a small header block that forces a large, attacker-controlled amount of CPU (and transient memory), a denial-of-service amplification. This issue affects hpax from 0.1.1 before 1.0.4.
Affected products
- elixir-mint hpax: from 0.1.1 before 1.0.4 — fixed in 1.0.4
How to fix
Upgrade to a fixed version: elixir-mint hpax 1.0.4. Check the vendor advisory for mitigations.
References
- https://cna.erlef.org/cves/CVE-2026-58226.html
- https://github.com/elixir-mint/hpax/commit/1ba4bb2dc91e80089cf89c73970ac3ded76f17eb
- https://github.com/elixir-mint/hpax/security/advisories/GHSA-jj2p-32j7-whj2
- https://osv.dev/vulnerability/EEF-CVE-2026-58226
- https://github.com/elixir-mint/hpax/security/advisories/GHSA-jj2p-32j7-whj2
Get alerted when CVE-2026-58226 or the next vulnerability affects your stack