What’s Vulnerable › Vulnerabilities
CVE-2026-58237: Multiple vulnerabilities in SAP Business AI Platform (Approuter)
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-11 · updated 2026-10-24
- Weakness: CWE-862
Description
WebSocket of SAP Approuter does not perform sufficient authorization checks in certain functionality. An attacker with low privileges could exploit this to access restricted functionality. Successful exploitation could allow the attacker to read sensitive information and perform limited modifications, resulting in a high impact on confidentiality and a low impact on integrity. There is no impact on availability.
Affected products
- SAP_SE SAP Business AI Platform (Approuter): before 23.0.0 — fixed in 23.0.0
How to fix
Upgrade to a fixed version: SAP_SE SAP Business AI Platform (Approuter) 23.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-58237 or the next vulnerability affects your stack