What’s Vulnerable › Vulnerabilities
CVE-2026-58252: NATS Server: Subscribe Authz Bypass via Wildcard-Overlap
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-08 · updated 2026-10-25
- Weakness: CWE-285
Description
NATS Server is a high-performance server for NATS.io, the cloud and edge native messaging system. Prior to 2.14.0, 2.12.7, and 2.11.16, an authenticated user could receive messages on denied subjects when a wildcard subscription overlapped with a configured wildcard deny rule but was not a subset of it, and queue subscriptions could also affect delivery to legitimate queue consumers. This issue is fixed in versions 2.14.0, 2.12.7, and 2.11.16.
Affected products
- nats-io nats-server: before 2.11.16; from 2.12.0 before 2.12.7 — fixed in 2.11.16, 2.12.7
How to fix
Upgrade to a fixed version: nats-io nats-server 2.11.16, 2.12.7. Check the vendor advisory for mitigations.
References
- https://github.com/nats-io/nats-server/commit/8ced85a11497f86704a95d960281480ce037386b
- https://github.com/nats-io/nats-server/commit/a42a6d1e258eb5c3a2190384d31965a4b715e854
- https://github.com/nats-io/nats-server/commit/e611ca9604697b02d8f22beb76037400a9cf72e6
- https://github.com/nats-io/nats-server/releases/tag/v2.11.16
- https://github.com/nats-io/nats-server/releases/tag/v2.12.7
- https://github.com/nats-io/nats-server/releases/tag/v2.14.0
- https://github.com/nats-io/nats-server/security/advisories/GHSA-wh7g-5m82-pmhr
Get alerted when CVE-2026-58252 or the next vulnerability affects your stack