What’s Vulnerable › Vulnerabilities
CVE-2026-58280: .NET Denial of Service Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-13 · updated 2026-10-31
- Weakness: CWE-674
Description
Uncontrolled recursion in .NET allows an unauthorized attacker to deny service over a network.
Affected products
- Microsoft .NET 10.0 runtime: from 10.0.0 before 10.0.13 — fixed in 10.0.13
- Microsoft .NET 11.0 runtime: from 11.0.0 before 11.0.0-rc.2 — fixed in 11.0.0-rc.2
- Microsoft .NET 8.0 runtime: from 8.0.0 before 8.0.32 — fixed in 8.0.32
- Microsoft .NET 9.0 runtime: from 9.0.0 before 9.0.21 — fixed in 9.0.21
- Microsoft .NET Framework 3.5: from 3.5.0 before 2.0.50727.9188 AND 3.0.30729.9171 — fixed in 2.0.50727.9188 AND 3.0.30729.9171
- Microsoft .NET Framework 3.5 AND 4.6.2/4.7/4.7.1/4.7.2: from 3.0.0.0 before 2.0.50727.8987 AND 3.0.30729.8982 AND 4.7.4150.0 — fixed in 2.0.50727.8987 AND 3.0.30729.8982 AND 4.7.4150.0
- Microsoft .NET Framework 3.5 AND 4.7.2: from 4.7.0 before 2.0.50727.9073 AND 3.0.30729.9070 AND 4.7.4150.0 — fixed in 2.0.50727.9073 AND 3.0.30729.9070 AND 4.7.4150.0
- Microsoft .NET Framework 3.5 AND 4.8: from 4.8.0 before 2.0.50727.9073 AND 3.0.30729.9070 AND 4.8.4811.0 — fixed in 2.0.50727.9073 AND 3.0.30729.9070 AND 4.8.4811.0
- Microsoft .NET Framework 3.5 AND 4.8.1: from 4.8.1 before 2.0.50727.9188 AND 3.0.30729.9171 AND 4.8.9363.0 — fixed in 2.0.50727.9188 AND 3.0.30729.9171 AND 4.8.9363.0
- Microsoft .NET Framework 4.6.2/4.7/4.7.1/4.7.2: from 4.7.0 before 4.7.4150.0 — fixed in 4.7.4150.0
- Microsoft .NET Framework 4.8: from 4.8.0 before 4.8.4811.0 — fixed in 4.8.4811.0
- Microsoft .NET Framework 4.8.1: from 4.8.0.0 before 4.8.9363.0 — fixed in 4.8.9363.0
- Microsoft Visual Studio 2026 version 18.10: from 18.10.0 before 18.10.4 — fixed in 18.10.4
- Microsoft Visual Studio 2022 version 17.14: from 17.14.0 before 17.14.42 — fixed in 17.14.42
How to fix
Upgrade to a fixed version: Microsoft .NET 10.0 runtime 10.0.13; Microsoft .NET 11.0 runtime 11.0.0-rc.2; Microsoft .NET 8.0 runtime 8.0.32; Microsoft .NET 9.0 runtime 9.0.21; Microsoft .NET Framework 3.5 2.0.50727.9188 AND 3.0.30729.9171; Microsoft .NET Framework 3.5 AND 4.6.2/4.7/4.7.1/4.7.2 2.0.50727.8987 AND 3.0.30729.8982 AND 4.7.4150.0; Microsoft .NET Framework 3.5 AND 4.7.2 2.0.50727.9073 AND 3.0.30729.9070 AND 4.7.4150.0; Microsoft .NET Framework 3.5 AND 4.8 2.0.50727.9073 AND 3.0.30729.9070 AND 4.8.4811.0; Microsoft .NET Framework 3.5 AND 4.8.1 2.0.50727.9188 AND 3.0.30729.9171 AND 4.8.9363.0; Microsoft .NET Framework 4.6.2/4.7/4.7.1/4.7.2 4.7.4150.0; Microsoft .NET Framework 4.8 4.8.4811.0; Microsoft .NET Framework 4.8.1 4.8.9363.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-58280 or the next vulnerability affects your stack