What’s Vulnerable › Vulnerabilities
CVE-2026-58302
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-30 · updated 2026-06-30
- Weakness: CWE-22
Description
rtapi_app in linuxcnc-uspace in LinuxCNC before 2.9.9 allows privilege escalation. It is installed SUID root and loads shared library modules via dlopen() by using a user-supplied module name. Insufficient validation of the module name allows path traversal, enabling an unprivileged local user to load an arbitrary shared library. Because the process retains elevated privileges during module loading, this results in local privilege escalation to root.
Affected products
- LinuxCNC: before 2.9.9 — fixed in 2.9.9
How to fix
Upgrade to a fixed version: LinuxCNC 2.9.9. Check the vendor advisory for mitigations.
References
- https://bugs.debian.org/1140943
- https://github.com/LinuxCNC/linuxcnc/commit/00d534c87464a3ed446656998aa02b8abc74b391
- https://github.com/LinuxCNC/linuxcnc/commit/ea7cd579d39b586952a42e3da9a26d3e36e7a272
- https://github.com/LinuxCNC/linuxcnc/compare/v2.9.8...v2.9.9
Get alerted when CVE-2026-58302 or the next vulnerability affects your stack