What’s Vulnerable › Vulnerabilities
CVE-2026-58319: Apache Doris: Improper Authentication in Frontend HTTP API
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-14 · updated 2026-10-24
- Weakness: CWE-306
Description
Certain Apache Doris FE HTTP REST administrative APIs were accessible without proper authentication. An unauthenticated attacker with network access to the FE HTTP service could perform unauthorized administrative operations, potentially affecting cluster integrity and availability and leading to cluster instability or denial of service. This issue affects Apache Doris versions prior to 3.1.0. Users are advised to upgrade to Apache Doris 3.1.0 or later.
Affected products
- Apache Software Foundation Apache Doris: before 3.1.0 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Doris 3.1.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/cob5mxkyr1k81o8v91hox2hld6zh25b4
- http://www.openwall.com/lists/oss-security/2026/07/14/3
Get alerted when CVE-2026-58319 or the next vulnerability affects your stack