What’s Vulnerable › Vulnerabilities
CVE-2026-58451: Horde IMP < 7.0.1 Path Traversal via Compose.php img src
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-01 · updated 2026-10-25
- Weakness: CWE-22
Description
Horde IMP before 7.0.1 contains a path traversal vulnerability in lib/Compose.php that allows authenticated attackers to read arbitrary files from the server filesystem by embedding traversal sequences after a CKEditor path prefix in img src URLs. Attackers can bypass the stripos() prefix validation by appending sequences such as traversal segments after the matching prefix, causing file_get_contents() to read sensitive files whose contents are then exfiltrated as MIME parts in outgoing email; unauthenticated exploitation is also achievable via CSRF against an active authenticated session.
Affected products
- horde imp: before 7.0.1 — fixed in 7.0.1
How to fix
Upgrade to a fixed version: horde imp 7.0.1. Check the vendor advisory for mitigations.
References
- https://blog.evan.lat/posts/CVE-2026-58451/
- https://github.com/horde/imp/commit/fba972fab72ee6871e5d56e6390bee38593085de
- https://github.com/horde/imp/pull/85
- https://github.com/horde/imp/releases/tag/v7.0.1
- https://www.horde.org/apps/imp
- https://www.vulncheck.com/advisories/horde-imp-path-traversal-via-compose-php-img-src
- http://seclists.org/fulldisclosure/2026/Jul/8
Get alerted when CVE-2026-58451 or the next vulnerability affects your stack