What’s Vulnerable › Vulnerabilities
CVE-2026-58473: Cognee < 1.2.0 Unauthorized LLM Configuration Overwrite via /api/v1/settings
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-07 · updated 2026-10-25
- Weakness: CWE-306
Description
Cognee before 1.2.0 contains an improper access control vulnerability that allows unauthenticated attackers to overwrite the global LLM provider configuration by self-registering an account and calling the settings endpoint, which performs no admin or superuser check. Attackers can redirect all LLM operations instance-wide to an attacker-controlled endpoint by exploiting the process-wide singleton configuration cache, enabling exfiltration of prompts, uploaded documents, extracted entities, and knowledge graph content from all users.
Affected products
- topoteretes cognee: before 1.2.0 — fixed in 1.2.0
How to fix
Upgrade to a fixed version: topoteretes cognee 1.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/topoteretes/cognee/commit/d10b1b77e2157c6238fd4d1acb1923a048991699
- https://github.com/topoteretes/cognee/issues/3084
- https://github.com/topoteretes/cognee/releases/tag/v1.2.0
- https://www.vulncheck.com/advisories/cognee-unauthorized-llm-configuration-overwrite-via-api-v1-settings
Get alerted when CVE-2026-58473 or the next vulnerability affects your stack