What’s Vulnerable › Vulnerabilities
CVE-2026-58566
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-01 · updated 2026-09-04
- Weakness: CWE-863
Description
Dell PowerStore, an Incorrect Authorization vulnerability. A low privileged attacker with remote access could potentially exploit this vulnerability, leading to Elevation of privileges.
Affected products
- Dell PowerStore 1000T: before 4.1.0.6-2771237 or later; before 4.3.1.2-2771239 or later — fixed in 4.1.0.6-2771237 or later, 4.3.1.2-2771239 or later
- Dell PowerStore 1200T: before 4.1.0.6-2771237 or later; before 4.3.1.2-2771239 or later — fixed in 4.1.0.6-2771237 or later, 4.3.1.2-2771239 or later
- Dell PowerStore 3000T: before 4.1.0.6-2771237 or later; before 4.3.1.2-2771239 or later — fixed in 4.1.0.6-2771237 or later, 4.3.1.2-2771239 or later
- Dell PowerStore 3200Q: before 4.1.0.6-2771237 or later; before 4.3.1.2-2771239 or later — fixed in 4.1.0.6-2771237 or later, 4.3.1.2-2771239 or later
- Dell PowerStore 3200T: before 4.1.0.6-2771237 or later; before 4.3.1.2-2771239 or later — fixed in 4.1.0.6-2771237 or later, 4.3.1.2-2771239 or later
- Dell PowerStore 5000T: before 4.1.0.6-2771237 or later; before 4.3.1.2-2771239 or later — fixed in 4.1.0.6-2771237 or later, 4.3.1.2-2771239 or later
- Dell PowerStore 500T: before 4.1.0.6-2771237 or later; before 4.3.1.2-2771239 or later — fixed in 4.1.0.6-2771237 or later, 4.3.1.2-2771239 or later
- Dell PowerStore 5200Q: before 4.1.0.6-2771237 or later; before 4.3.1.2-2771239 or later — fixed in 4.1.0.6-2771237 or later, 4.3.1.2-2771239 or later
- Dell PowerStore 5200T: before 4.1.0.6-2771237 or later; before 4.3.1.2-2771239 or later — fixed in 4.1.0.6-2771237 or later, 4.3.1.2-2771239 or later
- Dell PowerStore 7000T: before 4.1.0.6-2771237 or later; before 4.3.1.2-2771239 or later — fixed in 4.1.0.6-2771237 or later, 4.3.1.2-2771239 or later
- Dell PowerStore 9000T: before 4.1.0.6-2771237 or later; before 4.3.1.2-2771239 or later — fixed in 4.1.0.6-2771237 or later, 4.3.1.2-2771239 or later
- Dell PowerStore 9200T: before 4.1.0.6-2771237 or later; before 4.3.1.2-2771239 or later — fixed in 4.1.0.6-2771237 or later, 4.3.1.2-2771239 or later
How to fix
Upgrade to a fixed version: Dell PowerStore 1000T 4.1.0.6-2771237 or later, 4.3.1.2-2771239 or later; Dell PowerStore 1200T 4.1.0.6-2771237 or later, 4.3.1.2-2771239 or later; Dell PowerStore 3000T 4.1.0.6-2771237 or later, 4.3.1.2-2771239 or later; Dell PowerStore 3200Q 4.1.0.6-2771237 or later, 4.3.1.2-2771239 or later; Dell PowerStore 3200T 4.1.0.6-2771237 or later, 4.3.1.2-2771239 or later; Dell PowerStore 5000T 4.1.0.6-2771237 or later, 4.3.1.2-2771239 or later; Dell PowerStore 500T 4.1.0.6-2771237 or later, 4.3.1.2-2771239 or later; Dell PowerStore 5200Q 4.1.0.6-2771237 or later, 4.3.1.2-2771239 or later; Dell PowerStore 5200T 4.1.0.6-2771237 or later, 4.3.1.2-2771239 or later; Dell PowerStore 7000T 4.1.0.6-2771237 or later, 4.3.1.2-2771239 or later; Dell PowerStore 9000T 4.1.0.6-2771237 or later, 4.3.1.2-2771239 or later; Dell PowerStore 9200T 4.1.0.6-2771237 or later, 4.3.1.2-2771239 or later. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-58566 or the next vulnerability affects your stack