What’s Vulnerable › Vulnerabilities
CVE-2026-58578: LobeChat < 2.2.10-canary.15 - Regular Expression Denial of Service in GitHub Skill Import
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-02 · updated 2026-07-14
- Weakness: CWE-1333
Description
LobeChat before version 2.2.10-canary.15 contains a regular expression denial of service (ReDoS) vulnerability that allows authenticated attackers to block the Node.js event loop by supplying a catastrophic-backtracking pattern in a GitHub repository URL path during skill import. Attackers can craft a malicious basePath value containing unescaped regex metacharacters such as catastrophic-backtracking patterns, which are injected into a dynamically constructed regular expression in the findSkillMd function and executed synchronously against archive entries, denying service to all concurrent users for tens of seconds per request.
Affected products
- lobehub: before 2.2.10-canary.15 — fixed in 2.2.10-canary.15
How to fix
Upgrade to a fixed version: lobehub 2.2.10-canary.15. Check the vendor advisory for mitigations.
References
- https://github.com/lobehub/lobehub/commit/349bbe326eb8635d6d9c6a96d12702681ae3a84a
- https://github.com/lobehub/lobehub/issues/16494
- https://github.com/lobehub/lobehub/pull/16548
- https://github.com/lobehub/lobehub/releases/tag/v2.2.10-canary.15
- https://www.vulncheck.com/advisories/lobechat-canary-15-regular-expression-denial-of-service-in-github-skill-import
Get alerted when CVE-2026-58578 or the next vulnerability affects your stack